MorganExp

Morgan +8 Forum

Plus 8 Turn Signal Issues

AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor

Morganaddict Ronald Blair
Phoenix, Arizona, USA   USA
I have a 77 Plus 8. The left side turn signals both front and back turn on and stay solid when I turn on the left turn signal. When I turn on the right side those lights work just fine. The four way flasher works fine and all lights blink as they should in that mode. So what is up with the left hand side not working? Any thoughts?.

. Hide banner ads & support this website by becoming a > Gold Supporting Member <
TCTND Phil T
Santa Cruz, California, USA   USA
Generally if they light but don't blink it means not enough current is flowing to heat the bimetalic strip in the flasher enough to operate. It could mean poor connections or grounds on that side or one or more incorrect bulbs. If all those check out , you could try a modern flasher designed to operate incandescent or LED lights as these are not dependent on much current to operate.

regards,
Phil

Morganaddict Ronald Blair
Phoenix, Arizona, USA   USA
So the fact that the four way flashers work fine has no impact?

. Hide banner ads & support this website by becoming a > Gold Supporting Member <
TCTND Phil T
Santa Cruz, California, USA   USA
Four bulbs would draw plenty of current; two might not if they were poorly connected or grounded or incorrectly sized.

Morganaddict Ronald Blair
Phoenix, Arizona, USA   USA
Now I see what you are saying. Thanks for your thoughts on this.

. Hide banner ads & support this website by becoming a > Gold Supporting Member <

To add your reply, or post your own questions

Members Sign In   or   Create an Account

Registration is FREE and takes less than a minute!


Having trouble posting or changing forum settings?
Read the Forum Help (FAQ) or contact the webmaster





Join The Club

Sign in to ask questions, share photos, and access all website features

Your Cars

1968 Morgan 4 4

Text Size

Larger Smaller
Reset Save

Sponsor Links